Pecan Smoke Ring

Discussion in 'Woods for Smoking' started by woodman3, Sep 13, 2014.

  1. woodman3

    woodman3 Smoke Blower


    Question for avid pecan users. I primarily use hickory and cherry. The last two times I have used pecan I haven't achieved the smoke ring I want. Does pecan produce less smoke ring than hickory for example. What am I doing wrong?
     
  2. What kind of smoker are you using? what temp are you running?

    Happy smoken.

    David
     
  3. dirtsailor2003

    dirtsailor2003 Smoking Guru OTBS Member

    Certain woods do create different smoke rings. From what I've found milder woods don't create good smoke rings. I really don't care about the smoke ring. For me it's about the flavor.
     
  4. noboundaries

    noboundaries Smoking Guru OTBS Member SMF Premier Member

    If you changed nothing else you are not doing anything wrong.  There are arguments as long as the day about wood and smoke rings.  The common wisdom is that the wood used shouldn't make any difference in the smoke ring because the ring is caused by combustion chemicals in the smoke interacting with liquids in the meat.  The smoke ring is caused by the nitric acids that develop in the surface layer of the meat.

    That said, I too have noticed differences in smoke rings, but I am using a charcoal smoker with chunks of wood.  Hickory, mesquite, and cherry seem to give me a better smoke ring.  Pecan, apple, and oak seem to give less, and I've been using a lot of oak lately. 

    If a smoke ring is your goal, mix a little curing salt (Morton's Tender Quick) in your rub which adds more nitrogen compounds to the meat surface creating a better smoke ring no matter what wood is used.  I often use a small amount of curing salt (Prague Powder #1) in my brines and/or injections (1/2 tsp per 12.5 lbs of meat) because I like the flavor it gives the meat, not for the smoke ring.       
     
  5. woodman3

    woodman3 Smoke Blower

    I have a Yoder offset. I have not had issues before getting smoke ring. But this time I did have runaway temps. I guess that may have caused it.
     

Share This Page