Regulator Problem?

Discussion in 'Propane Smokers' started by mofo, Oct 15, 2010.

  1. mofo

    mofo Meat Mopper

    I was using my Big Block yesterday and could not get the temps to go above 180. I had plenty of gas in the tank. I reset the regulator by disconnecting, etc.  It improved for a while but noticed when I adjusted the control know the flame would get real long and lanky... If I shook the tank, the flame would turn back to a nice yellow with small blue tip. Every time I adjust temps, the flame would get all out of whack. I then started tapping the regulator on occasion and presto, the flame would once again become as it should. 

    Would you guess that my regulator is going bad and needs replaced? Is there a difference between a regulator for a gas grill and one for a gas smoker?
     
  2. bmudd14474

    bmudd14474 Smoking Guru Staff Member Administrator Group Lead OTBS Member SMF Premier Member

    It could be the regulator. Have you tried a different tank?
     
  3. eman

    eman Smoking Guru Staff Member Moderator OTBS Member

    Sounds like you have trash in your line at the connection between the tank and the line.
     
  4. mofo

    mofo Meat Mopper

    Yes, I tried a different tank and also blew out the burner and line with my air compressor. Could only find regulators locally that had a short hose crimped on to them, which could not be removed, so ended up calling Landmann-USA and ordered through them. $30 + $12 for shipping. It includes everything, regulator, hose and the brass orifice end. They also threw in the control knob I was looking for... 

    Pretty good folks to work with...
     
  5. mofo

    mofo Meat Mopper

    got the hose, regulator, knob and brass orfice [​IMG]... My flame is once again a thing of beauty...
     

Share This Page