MES 30 electrical problem

Discussion in 'Electric Smokers' started by sslay94, Aug 3, 2015.

  1. sslay94

    sslay94 Newbie

    I tried to use my MES 30 over the weekend. I plugged it in, turned it on, hit the temp set button and all it did was shut off but there was a loud clicking noise coming from the display. Once I unplugged it the clicking went away. I plugged it back in and it did the same thing. I went through this ten or so times until it finally let me set the temp and time. Sometime the unit would shut off while setting the temp, sometime while setting the time, and sometimes after just turning it on. After 3 or so hours of cooking I checked it and the unit had completely shut off. I restarted it and it worked fine till the ribs were done.  I keep the smoker in my garage with a cover on it when not in use. I checked the electrical cord to make sure it wasn't damaged and even tried a different outlet. Any ideas of whats going on?
  2. tumbleweed1

    tumbleweed1 Smoking Fanatic

    Is this a Gen I or Gen II MES?

    Did the cord ever feel warm to you?

    Were you using an extension cord?

    Is the outlet one that you had used before?

    Does the plug fit loosely in the outlet or tight?

  3. sslay94

    sslay94 Newbie

    This is a Gen 1 unit and the cord never felt hot. At first I was using an extension cord then I moved the smoker closer to the outlet and plugged it in directly. I then moved to another outlet with the same result. Both outlets are in use from time to time and seem to work fine when something else is plugged into them. I ran a shop vac on the one for twenty minutes or so after unplugging the MES. The plug does fit tight in the outlet and extension cord.
  4. tumbleweed1

    tumbleweed1 Smoking Fanatic

    How old is this smoker & how many smokes you reckon you did with it?

    I'm wondering if the connector for the heating element is corroded.

  5. sslay94

    sslay94 Newbie

    I just got it last November and and I'd say maybe 20 smokes on it.
  6. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Un plug the smoker, take the cover off of the connection location.... clean, sand, wire brush the corroded connection... strip to a new piece of wire... solder the stuff back together..... you will never have another problem.....

  7. sslay94

    sslay94 Newbie

    Great! Thanks for the help.
  8. sslay94

    sslay94 Newbie

    Much appreciate the help. I didn't see any corrosion but took the connections apart, cleaned them, and reconnected and it works great now.

Share This Page