Maverick thermo says LLL ?????

Discussion in 'Beef' started by xtexan, Feb 2, 2008.

  1. xtexan

    xtexan Meat Mopper

    I just plugged my Maverick in and the reading is LLL. Anyone have any idea what this is? My thermo is only 4-5 months old and has worked great until now.
     
  2. smoke freak

    smoke freak StickBurners

    Mine was reading LLL when it was below 32 degrees. held the probe in my hand a moment and it started readin temp.
     
  3. 3montes

    3montes Master of the Pit OTBS Member

    Great. I just submerged both probes in alternate boiling and then a few minutes later freezing water in order to check accuracy. I will have to power it up today to make sure it still works. [​IMG]
     
  4. packplantpath

    packplantpath Smoking Fanatic

    Yep, just means the temp is below it's range. Mine does it every time I turn it on for about 3 seconds then goes away. If I stick it in cold meat it sometimes takes a while.
     
  5. xtexan

    xtexan Meat Mopper

    Unfortunately mine has been at room temp. for about 3hrs and stil LLL. Could leaving the unit out in my storage box on my big smoker have done this in the freezing cold Ohio temps for almost two weeks??

    Texas Hunter I don't see the address to send it too.

    Thanks for the help guys!
     
  6. richtee

    richtee Smoking Guru OTBS Member

    DO NOT submerge the crimp <wire entry> of ANY probe in liquids!
     
  7. packplantpath

    packplantpath Smoking Fanatic

    Hmm, that is also what mine defaults to if the unit is on, but the probe is not plugged in. So I'm going to guess that there is a bad connection. Unfortunately, probably junk now.

    BTW, I just re-tested my probe this morning and it's reading 210 at boiling, so pretty close.
     
  8. 3montes

    3montes Master of the Pit OTBS Member

    Good I might be ok then...Sounds like these Mavericks are cheaply made. Are there any 2 probe thermometers of better quality available. I just spent 50 bucks shipping included on the Maverick (why do I think of Top Gun I hate that phony movie) So if that craps out I would like to buy something that will hang. Any suggestions?
     
  9. xtexan

    xtexan Meat Mopper

    Thanks Ken, it is the probe because I plugged the other one in and it works fine. I will try to get another one from Mav. Hopefully freeeeee!
     
  10. xtexan

    xtexan Meat Mopper

    Actually free will not be an option.... It helps if you look at the wire to see if it is cut, mine was. I must have shut it in my storage box.
    Oh well, I guess I will have to invest the $12.95 in a new one.
     
  11. richtee

    richtee Smoking Guru OTBS Member

    All will default to something with no probe.

    OK basic electronics lesson:
    Digital therms work on the principle that certain substances change electrical resistivity with temperature. They basically apply a voltage to the element <the probe tip> and measure the voltage drop across it due to it's resistance value at the ambient temp.

    Sooo..any water, or foreign substances that get into the probe will affect the resistance change. Some substances will destroy the element, as it's usually a semiconductor material made with exacting specifications to produce it's intrinsic temperature response.

    Also, any increase in the contact resistance of the jack/plug assembly will toss a wrench into the works. Corrosion and moisture will cause this.

    Keep anything from having any way to get inside the probe!

    Additionally, the point where the probe meet the wire is more subject to mechanical strain. Avoid bending/flexing at that point.
     
  12. smoke.eater

    smoke.eater Fire Starter

    I had mine replaced for free when it was over 90 days old, almost a year old. When I phoned to complain about its longevity they didn't even ask how old it was ...they just asked for my address and apologized for the inconvience. I got the new one 5 days later in the mail to Canada.
    [​IMG]
     

Share This Page