Masterbuilt heating element replacement????

Discussion in 'Electric Smokers' started by kudu2222, Aug 30, 2016.

  1. kudu2222

    kudu2222 Newbie

    I have been trying since April 4th to get a heating element for my 40 inch smoker (pt # 9907120027). I have been put off time and again with excuses and delays. Once again this afternoon I was told that their expected delivery is October 7th. I no longer believe anything I am being told. WHERE can I get a heating element, even a universal element that is approx 7" X 8", I am not sure what wattage I need.

    Frustrated, I should have bought a Treager
     
  2. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Is it the element for sure or did the wires just burn off, like happens in so many MB smokers.....
     
  3. kudu2222

    kudu2222 Newbie

    DaveOmak, WELL CRAP!!!! I just checked and the wire is burnt off the one terminal!!!! What is a simple fix and how did you prevent it from happening again?  There is only about 1 1/4" of wire left to work with. I can't believe I have wasted a whole summer of smoking. Thank you for your help!!!!
     
  4. dr k

    dr k Master of the Pit

    I can send you a couple pigtail high temp connectors.  I also had no lead to work with.  I have over a dozen I got for $8.00, brass plated in nickel 900*F.  I'll just mail to you for free.  It's better than having them sit around here.  I double shrink tube them for heat resistance.  Here's a couple pics.  If you want two, just PM me and I'll drop them in the mail.



    I soldered all my joints but you can wire nut it like MB sends there's, if necessary.  I used 14 gauge instead of Masterbuilt's 16.  I've got plenty for now and no problem to make in five minutes.  Many have said to look at the element quick disconnect first so I'm passing the buck!   

    -Kurt
     
    uncle eddie likes this.
  5. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Clean BOTH terminals on the element with some fine sand paper....  Strip both wires back to good wire....  tin the wires....  tin the new female spade lugs and solder them...    slide the spades on the element spades...  then I would solder them in place...  

    High amperage is what causes the spades to burn off...  poor connections....  any spades will work as long as they are soldered...   If you can get some fiberglass electrical tape, wrap all the new work with it...  

    That fix should last forever...  mine has been operating for 5+ years with the fix.....  there's no way it will burn off with good solder joints...  

    If they are plastic insulated spades, cut off the plastic...
     
  6. kudu2222

    kudu2222 Newbie

    Kurt, THANK YOU! I see in the pictures you provided how you repaired it. I'll run up to my local hardware store tomorrow and get my needed repairs. Thank you for the offer of the wire etc... I truly appreciate your advice!!!! Bob Phillips
     
  7. kudu2222

    kudu2222 Newbie

    Dave, Thank you again for your advice on the burned wires on my Masterbuilt smoker. I have it repaired and smoked some ribs today. Sure is good to have it up and working!  Thank you again for your help, I really appreciate it.

    Bob Phillips
     
  8. kudu2222

    kudu2222 Newbie

    Kurt, Thank you again for your advice on the burned wires on my Masterbuilt smoker. I have it repaired and smoked some ribs today. Sure is good to have it up and working!  Thank you again for your help, I really appreciate it.

    Bob Phillips
     
  9. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Bob, morning and thanks....   We have tons of knowledge to pass on....   we're not always right but pass it on anyways...  [​IMG]  ...

    Dave
     
    hoity toit likes this.
  10. graco

    graco Smoke Blower

    Question; I just changed the element, wires and connectors. When I turn it on it heats up to 120 degrees or so and then it stops heating. What could be wrong?
     
  11. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Does the power go out ??   Will the smoker cool then start heating again ??  Open the door and let it cool...    If it starts up again, it's the over temp snap switch...   
     
  12. graco

    graco Smoke Blower

    Power stays on. It cools but does not go back up in temp. Where is that switch?
     
  13. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    So it won't turn back on after it cools to say, 70 degrees or so ???   if it's the over temp snap switch it should....   ONLY because your smoker warms up when turned on....    

    The snap switch is the round button thing on the left side, back wall of the smoker body.....

    Try this...  put an ice cube on it to cool it off fast and cold...  The smoker should turn on when that is done.....  unless something is haywire with the "re-wire" project you did...

    What all did you re-wire ??  Can you check the continuity of the wires to heating element connections ??   Are the connections solid and tight. ??
     
  14. graco

    graco Smoke Blower

    It did the same thing before I changed the wires.
     
  15. graco

    graco Smoke Blower

    This is how I hooked it up.
     
  16. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Do the ice thing on the snap switch.....   That will tell us "something".....   Like I noted....   If it starts cold, it should restart when it cools off.... 
     
  17. graco

    graco Smoke Blower

    I changed the connectors to the other side., It went up to 115 then I opened it until the temp dropped to 80, closed it and it would not come back up. I disconnected it, disassembled the install, reassembled it again and now it wont even heat past ambient temp. 
     
  18. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Did you try the ice on the snap switch ???
     
  19. graco

    graco Smoke Blower

    No. There's a flat bolt to the left, is that it? What good would it do if now it doesn't even go past 80?
     

Share This Page