Is my meat probe going out in my MES 40?

Discussion in 'Electric Smokers' started by strawman, Mar 13, 2012.

  1. I was doing a pork shoulder over the weekend and as I was reaching the final temps, my meat probe kept hopping around from 191 to 195.  After so long and it didn't go above 195, I went out and checked with another thermometer and it was 207.  The meat probe had never done that before, but, it scares me to use it again.  It was always right on the money before.

    Now, I am getting a maverick soon anyway, but, I just wanted opinions on what happened.  Is there some terminal I should maybe clean on the probe? Or?

    Thanks in advance for the responses.

    Adam
     
  2. adiochiro3

    adiochiro3 Master of the Pit OTBS Member

    Dont' know about the MES specifically, but you can test your thermo in boiling water for accuracy/stability.(212*).  Sounds like you have it under control with the Maverick coming tho.
     
  3. chef jimmyj

    chef jimmyj Smoking Guru Staff Member Moderator Group Lead OTBS Member

    Give Masterbuilt a call. I had a wonky Therm Probe and they sent a new one same day...JJ
     
  4. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Strawman, morning.....  Sounds like there may be water in the probe.... I do not know how that is possible but ?????   Does you MES 40 sit out in the rain ?????   Usually probes work or die.... not in between....   Dave
     
  5. My MES sits in a shed and has never seen a drop of rain.  I think I will try calling pursuant to JJ's suggestion and see where I get.  I should do another boil test.  I did one when I bought it and the probe said 211 at a full boil. 

    Thanks for the replies.
     

Share This Page