Where did I go wrong?

Discussion in 'Pork' started by mikhen, Apr 27, 2014.

  1. mikhen

    mikhen Newbie

    This was my first attempt in my new Masterbuilt electric smoker.     Pork Butt was in the smoker by 7am.    It was small,  only 3.5 pounds.     IT at 160,   I wrapped it in foil.    Seemed to reach it's plateau at 180,  as it sat there for about 45 minutes.    When the IT reached 204,  I checked other areas and they were at 207.     Took it out of the smoker,  double wrapped it in foil and towels,  then threw it in the cooler.     2 hours later,   it is no where near ready to pull apart.    It is now in the crock pot cooking.     However,   the chunks I did manage to break off it are mighty tasty.     But what did I do wrong?    
     
  2. geerock

    geerock Master of the Pit SMF Premier Member

    If you verified the IT with the masterbuilt meat therm that may be the problem. They tend to be way off.
     
  3. mikhen

    mikhen Newbie

    Thanx, that's a start. I even thougt of getting my other thermometer, but didn't. It'll have to wit for next time. I have it jh the crock right now with a little sweet baby rays, and boy is it good.
     
  4. pineywoods

    pineywoods Smoking Guru Staff Member Administrator Group Lead SMF Premier Member

    Always test a new thermometer then test them once in awhile just to make sure they are still accurate. Easy way to test is with boiling water.
     
  5. foamheart

    foamheart Smoking Guru OTBS Member SMF Premier Member

    What temperature was the box, not the IT of the meat, the cooking temp? Also anytime you have a doubt, use a toothpick on the meat to check tender before pulling.
     

Share This Page