Trouble with my Maverics....

Discussion in 'Slicers, Grinders, Tools, Equipment' started by oldschoolbbq, Jan 25, 2012.

  1. oldschoolbbq

    oldschoolbbq Smoking Guru OTBS Member

    Todd or anyone smarter than the Redichecks. I can get my chamber temp  to show-up,but the Food won't register.

    I checked them last nite and they worked OK , now today the unit won't let me pick up the signal , even out by the Smoker.

    Help me , please...
     
  2. oldschoolbbq

    oldschoolbbq Smoking Guru OTBS Member

    Look on my profile to see the Butts and the progress. Son took the first shots on his Droid and I can't get them on here...

    I'll keep on trying and get my camera later to show the progress[​IMG]
     
  3. tyotrain

    tyotrain Master of the Pit

    I no with mine i have to have the box that is remote on first than turn the other box on.. If i don't do it in that order it will not register..

     Have fun and Happy smoking
     
  4. chef jimmyj

    chef jimmyj Smoking Guru Staff Member Moderator Group Lead OTBS Member

    New Batteries is the first step...Then try a bigger hammer!...[​IMG]...Sorry to here you are having problems, Stan...JJ
     
  5. smokinal

    smokinal Smoking Guru Staff Member Moderator OTBS Member ★ Lifetime Premier ★

    Are you sure the probe is in all the way? Try wiggling it around where it plugs into the transmitter.
     
  6. tyotrain

    tyotrain Master of the Pit

    X2
     
  7. pat king

    pat king Fire Starter

    Yeah , I did the smart way and read the directions thouroly this time and found I had been turning them on backwardsd and the probes were'nt in well enough , DUH [​IMG]

    Thanks for the comeback , Stan      aka      oldschool [​IMG]
     
  8. venture

    venture Smoking Guru OTBS Member

    I'm holding back on this one till I get my new Maverick probe.  First one went bad after six smokes.  Old cheapie brand probes still chugging along.

    Now the Maverick meat probes are on back order.  I hope this means they are looking for a new supplier.

    Good luck and good smoking.
     
  9. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    Stan,

    It's all good advice

    Most of the time, the probes are not seated in all the way

    If they don't sync up, place both units next to each other and push the "Resync" button

    Even though the batteries are new, sometimes they don't work.  Try a set of new AAA batteries

    If it turns out your probes are bad, I can swap them out for new ones.

    I have 100 Sets of 6' Et-732 replacement Probes on order from Maverick

    ET-732 probes are delayed, and are due in 2/10/12

    Todd
     
  10. smokinal

    smokinal Smoking Guru Staff Member Moderator OTBS Member ★ Lifetime Premier ★

    I didn't even know there was a resync button. I better look at the directions again! [​IMG]
     
  11. scarbelly

    scarbelly Smoking Guru OTBS Member


    X2 - never had an issue so never looked
     
  12. I've had my Maverick ET-732 for two weeks now. The food probe is finicky on how it is plugged in to the transmitter. I have to push it in and turn it a little at the same time. The temp probe isn't like this.
     
  13. oldschoolbbq

    oldschoolbbq Smoking Guru OTBS Member

    It's all good now Todd, Dumba$$ me didn't read the directions correctly...[​IMG]  I ran them the whole 12 hrs. on Friday. thanks for the comback , Stan   aka   oldschool.

    P.S. , I love the freedom to come in and enjoy Coffee instead of it getting cold and yucky so quick.[​IMG]
     

Share This Page