New MES 40 Gen 1 dead!

Discussion in 'Electric Smokers' started by dvuong, Jul 29, 2015.

  1. dvuong

    dvuong Smoke Blower

    I just tried seasoning my newly delivered Gen 1 today.  I plugged it into the outlet and powered on.  Within just a couple of minutes of setting the smoker to heat to 275 the controller went dead.  I guess it tripped the GFCI.  I plugged directly into the outlet without an ext. cord. 

    My previous Gen 2 smoker never tripped the GFCI.  Is there something wrong with this unit?

    I've tried plugging it into a second outlet and it lasted a little longer this time but shut off again.  Time to call Amazon for a return? 
     
    Last edited: Jul 29, 2015
  2. bmaddox

    bmaddox Master of the Pit

    You tried it on another GFCI outlet? GFCI outlets can go bad but if it is tripping multiple GFCIs then it probably has a short or a bad ground. If it is new I would definitely return it. 
     
  3. rraczyla

    rraczyla Fire Starter

    I had the same problem with gen 1. I went through two gen 1s and both would trip gfci. I just got a replacement gen 2 and so far it hasn't shut off or tripped the gfci
     
  4. inkjunkie

    inkjunkie Master of the Pit

    Electronics...great when they work but....

    Call Masterbuilt. My Gen 1 came with a busted rack holder. They had no issue sending a replacement. Have seen several folks mention a problem similar to yours, from what I remember Masterbuilt took care of all of them...

    Hope you get your problem solved...
     
  5. rraczyla

    rraczyla Fire Starter

    I agree I would call them. I am on my third unit with he two replacements being free of charge
     
  6. inkjunkie

    inkjunkie Master of the Pit

    If you do call them, and they are going to just send replacement parts, make sure that you get them to give you a specific list of what you are,going to get. When I called about the broken rack the CSR that helped me,told me I would be getting a pair of brackets. Invoice in box said there was 2 brackets yet they only shipped one...
     

Share This Page