MES30 Shut off problem

Discussion in 'Electric Smokers' started by pbrown86, Apr 21, 2016.

  1. pbrown86

    pbrown86 Newbie


      I have a MES 30 (20070411).  I have only had it about a year (about a dozen smokes).  I have had an issue since early on, but it seems to have become more common.  When I turn on the smoker via the control panel, it sometimes will turn off and there will be a "clicking sound".  If I unplug and replug it in, it will turn back on, but when trying to program the temp and time, sometimes it will repeat with shutting off and the clicking sound.  My best luck has been to unscrew the control panel and let it sit on the top of the smoker but not screwed in and not "hooked" into the top with the guiding screw on the bottom of the control panel.   This will normally allow it to work as long as I don't touch the controls once it has started.  Any recommendations?
  2. chef jimmyj

    chef jimmyj Smoking Guru Staff Member Moderator Group Lead OTBS Member

    Sounds like an intermittent short or beak in the controller wires. Removing the screws and moving the controller moves the wires away from where it is shorting or pushes the break in the wire to make a better connection. Remove the controller completely and give it and the wires a good inspection...JJ
  3. Agree with jj,defenitely sounds like a loose connection.
    Last edited: Apr 21, 2016
  4. wade

    wade Master of the Pit OTBS Member SMF Premier Member

    Yes. Check the wires and connections. Try moving the wires while it is switched on to see if one in particular causes the unit to switch off. Be careful though when you do that.
  5. pbrown86

    pbrown86 Newbie

    Thanks guys.  I will take a look. Do you assume the issue is close to the controller since that is the only place I have access to the wires?
  6. chef jimmyj

    chef jimmyj Smoking Guru Staff Member Moderator Group Lead OTBS Member

    Most likely since moving the controller temporarily fixes it...JJ
  7. hangin1

    hangin1 Fire Starter

    Yea I have the same smoker and have the same problem. I called masterfully and they sent me a new digital head unit but still got the same problem so I'm thinking my problem is with the internal wiring! If you figure it out let me know because having to worry about the smoker shutting off during a cook sucks! Happy Smoking all!
  8. kaiax333

    kaiax333 Newbie

    +1 here

    I got my MES for Christmas 2015, done about 6-8 smokes and it's been fine. Most of those were briskets. 

    Got up at 4:00AM today to get a nice warm brisket for Memorial Day and worked great for the first 8 hours...then I noticed that it stopped. Unplugged and restarted, unplugged and restarted til it finally stayed. Came back an hour later....shutdown (and losing heat!) 

    Did everyone just call Masterbuilt? What was that experience like? 

    Much thanks!

  9. hangin1

    hangin1 Fire Starter

    Yea just call masterbuilt and they will probably send you a new heating element or digital head unit. I ended having to buy a new unit but they offered me one at a good price. Good luck and hope you get it fixed up.
  10. james95014

    james95014 Newbie

    I was recently gifted a problem MES 30 with rear controls & window, model #20070411.  It has the random shutdown, shutoff problem

    which was never able to be fixed even after multiple control unit changes.  Wanting to get to the bottom of the problem, I took it completely

    apart and reverse engineered the electronics.  I discovered that the internal power supply is being overloaded by design.  This and poor

    power distribution push it over the edge.  The box is designed with a little power supply and relay board in the bottom that connects via

    a long cable to the control unit on top.  The control unit gets +5V power through the cable.  With everything turned on, the little

    power supply is overloaded beyond rated capacity.  Then large power demand spikes come in from the control unit and relays which push the

    voltage down hard just for an instant.  When the voltage goes down hard enough, the control unit resets itself ending the smoke and

    giving you a bad surprise when you wake up.  This is compounded by trying to run power to the control unit through a long thin wire

    and no large decoupling capacitors in the control unit.

    The whole design is on the edge.  When you call customer service and they send out a new control unit, it's just luck that the new

    Control unit + Box combination pulls it back from the edge enough to work.  Over time ageing will push it back over the edge after

    you're out of warranty.  That was the experience of my boxes previous owner.  Other symptoms of the problem are shutting down

    when changing temperature, changing time or turning on the light.

    I worked up a fix that seems to work, add a large capacitor to the control unit.  The capacitor holds the voltage up enough during

    brown outs to avoid reset.  It's easy to take the back off the control unit and get to the spot on the board to add the capacitor.  

    These pictures show where it is.  I ended up with 1000uF just because I had a bunch laying around.  It just needs a big cap.  

    You can get caps on ebay.  To get a little more soldering room to attach the cap leads, scrape some of the green coating off the

    board to expose bare copper.  The left lead is Ground, the right is +V.  A 10V or higher capacitor is fine.  

    Last edited: Jul 19, 2016
  11. cmayna

    cmayna Master of the Pit OTBS Member SMF Premier Member

    To make life very simple for ya', you might consider modifying you MES with an Auber PID.

    It basically involves, disconnecting the current wire to the heating element and connect a power cord directly to the element. Once done, you plug the new power cord to the Auber unit and go from there...... Never looked back 😎

    Sent from my iPhone using Tapatalk
  12. blathnac

    blathnac Newbie

    Same kind of thing here for me.  After disconnecting and reconnecting the wires under the control it has been working.  Although I smoked a couple pork shoulders last night and when I came out to spritz and foil it was hot.  I noticed smoke coming out from under the control panel.  I moved the control panel and saw that smoke was coming out of the hole the wires go into.  Smoker well on its way to 300 so I turned it down to 100 and moved the meat to the oven in the house.  Came back outside and the element is still glowing red hot even after I set it to 100.  So I turn it off and watch to see if the element starts to cool.  It doesn't.  Still glowing red hot.  So I decide to disconnect both wires of the control unit and the element won't turn off.  It doesn't turn off until I unplug the power.  Looks like I'll be calling Masterbuilt.   
  13. johnmeyer

    johnmeyer Smoking Fanatic

    [edit]see my later post below before you do anything

    I realize this is an old thread, but I just wanted to thank James. I could have posted exactly the same thing he did (including the fact that this is a gifted, used unit). I searched the web and found that this model has dozens (perhaps hundreds) of identical complaints, including several YouTube videos that demonstrate exactly what James described.

    That is not my video, although it is the identical MES and the problem is precisely the same thing I am experiencing.

    I too am an EE and after taking apart the controller on top of the smoker, it was clear that it was fine and very unlikely to be the culprit. In addition, every single description of this problem has the same key piece of information: sometimes it works. This puzzled me at first: why would it work sometimes and not others? Why would it sometimes fail, without even turning on the heating element? For instance, I could sometimes get it to fail simply by turning on the light!

    I didn't want to open up the power supply at the bottom of the smoker, since it is riveted shut, but found a good photo on this site. It looked pretty basic. I at first thought perhaps there was some sort of ground-sensing circuitry (since there have been so many ground issues with MES units), but that didn't seem likely, and the failure mode didn't seem to correlate with anything having to do with ground.

    I then hooked up a volt meter to the power leads on the controller board and got only 4.8 volts (5.0 volts is a common standard). As I did various things, I saw the voltage go up and down a little. I probably should have put my scope on it to see how much AC ripple was present.

    Bottom line: I was starting to come to the same conclusion, namely that the power supply was pretty small and very remote and that the combination of these two things meant that whenever something happened to cause a voltage drop (pretty much any button press), the local voltage on the board dipped enough to shut off power from the digital chips, causing them to reset.

    Thus, a large capacitor might solve the problem by providing a larger amount of reserve energy, for a few milliseconds, whenever a pulse of current is needed.

    Thanks to James, I have confidence that this might actually do the trick. I'll write back tomorrow and let you know if this fixed the problem.

    [edit] The fix appears to be working. I used a 470 uF 25V cap. I desoldered and then took out the old cap because the extra 100uF isn't really needed. I then used its mounting holes to install the new capacitor. This avoided having to add wires on top of other components. I placed the cap over to the right of the circuit board and hot-glued it to the plastic chassis. I'm a little concerned about the hot glue melting, so I'm going to add a little epoxy or RTV (depending on what I have on hand).

    [edit2]Here's a photo of the installed fix. I used a little epoxy to supplement the hot glue. I covered both the leads and the cap itself in heat shrink tubing, just in case it were to break free (unlikely, especially since it is trapped above by the bottom cover, once it is put back on). You'll see two wires coming from each lead of the cap because the only wire I had on hand was 30 gauge, which is a little small to handle the current. So, I used two wires instead of one.

    Last edited: Jan 31, 2017
  14. johnmeyer

    johnmeyer Smoking Fanatic

    Well, I fired up the smoker today, and the controller is back to its old tricks. So, the fix did not work.

    Masterbuilt is sending a new controller (their customer support sure is amazing). I'll see if that helps. If it doesn't then the next step is to re-do the power supply in the riveted box at the bottom of the smoker.
  15. barryvabeach

    barryvabeach Fire Starter

    Thanks for posting the update ,  it may help others in the same place,  Sorry the fix didn't work for you, but hope you get it sorted out.  If all else fails, it is pretty easy to wire a third party controller like an auber  or even a  diy controller for around $60
  16. johnmeyer

    johnmeyer Smoking Fanatic

    Thanks. I haven't read many of the diy controller threads because the idea always seemed wrong. Most of them were oriented toward reducing the temperature swings, but it seems to me that if you reduced the temp swings to only 1-2 degrees, the chip loader would never get really ripping hot (except while initially getting up to temp) and therefore the chips wouldn't smoke very well. I've always thought that the big temperature swings were intentional, by design.

    Of course, like many people, I know use the AMNPS for my smoke, but for those who still use the chip loader, I would think the fancy controller might not be a good idea.

    If I do end up building my own controller, my understanding is that all I have to do is figure out which pair of leads is the sensor; which is the control for the relay; and which is power (already have that figured out). I guess someone has already posted that information.

    First thing is to see if the new controller fixes things.
  17. monstaroo

    monstaroo Newbie

    I had some issues with the smoker shutting off or getting too hot even after MB replaced my control panel. My solution was to buy a tappecue. It has four probes and I can set my chamber temp probes to alert my phone (very loud) if they go above or below the temperatures I set. This way if my smoker shuts off, I should be woken up or otherwise alerted to get back and check things out. Because they're on wifi, it doesn't matter if I tin to the store, I can still monitor temps real time. But yes, they're expensive... And yes, a battery back up on the tappecue and your modem/router is needed if you want protection against power outages.
  18. johnmeyer

    johnmeyer Smoking Fanatic

    Masterbuilt sent me a replacement controller. I've done three smokes, and I've had no problems. The temperature setting is off, but I simply use my Maverick to tell me the correct temperature, adjust the MES temp setting accordingly, and all is good.

    As others have noted in these forums, Masterbuilt's support is amazingly good. I wrote back to them thanking them, and promised to spread the word about their support.
    Last edited: Feb 5, 2017
  19. blakshukvw

    blakshukvw Newbie

    I'm having the same issue. On my second controller. I'm interested in doing this mod listed above but I'm no electrician.
    I've also looked into pid controllers but they pretty expensive. Can anyone point me in a direction of an affordable pid controller?
  20. If you leave the cover plate off the back wires will not overheat.
    I got a PID controller off of tomtop dot com its a heating only PID for $10.05 sorry dont have the part#
    Go to amazon and order2 type k thermocouples for 6 bucks and a solid state relay 25amp with 3-32 v dc control, and o ly other thing you will need is a small power supply that has a dc output, i have less than $20 bucks in it and it works awesome!

Share This Page