MES30 heating element died!!

Discussion in 'Electric Smokers' started by diverboss, Feb 13, 2016.

  1. I have MES 30 analog smoker, love it, except for the fact that I am now on my (soon to be) third heating element.  Any body else have this problem?
     
  2. miatawnt2b

    miatawnt2b Fire Starter

    How old is it, how long does each element last and how often do you use it?  I would say there is probably something wrong with the smoker. I'd try and get Masterbuilt to give you a new one, even if out of warranty considering you've dumped 3 elements in it already.

    -J
     
  3. bearcarver

    bearcarver Smoking Guru OTBS Member

    I guess most Masterbuilt Analogs on this forum are older ones, but I can't remember a lot of heating element troubles mentioned by Analog owners.

    The only fix I had to do in a combined 9 years of MES Digital units was a wire going to my heating element. Are you sure it's not just the wire corroded off??

    How old is yours?

    Bear
     
  4. miatawnt2b

    miatawnt2b Fire Starter

    failed to read the word analog in the OP. doh.
     
  5. tsin

    tsin Smoke Blower

    I had the wire burn off on the heating element too I thought it was the element Glad I found before I ordered a new element
     
  6. Smoker is less than a year old, element is less than 2 months old. I use it once or twice a month, and keep it covered when not in use.
     
  7. bearcarver

    bearcarver Smoking Guru OTBS Member

    Then if it's not the wire this time, I would have to say there's something else wrong that is causing this.

    I would call Masterbuilt---They have a Great CS these days.

    Bear
     
  8. took the back off of the element and this is what I discovered:




    Any clues as to why this happens. TWICE??
     

Share This Page