MES problem

Discussion in 'Electric Smokers' started by wesb, Nov 9, 2009.

  1. wesb

    wesb Fire Starter

    i've been using a MES for over a year now with no problems. when I start it up now it won't heat up, only a few inches of the element will get warm, that's it. Any suggetions? the only thing i've done since the last smoke was clean it out after stuffing it full of briskets for a wedding.
     
  2. chainsaw

    chainsaw Smoking Fanatic

    Hey,
    I am a newer member (June), and have an MES. They are notorius for electrical problems, and rest assured you will have a quick response from more educated smokers than myself. Only I wish I had splurged for the Cookshack, even tho it has less smoking space-or differently arranged space. And cost's 3 times as much.
    Lots of folks on here have MES. Hopefully they won't suggest rebuilding the whole unit. But they might.
    Good luck![​IMG]
     
  3. bigwheel

    bigwheel Smoking Fanatic

    Yep sounds like you need a new element. Now if it was a Brinkmann I just send you over to Academy to get a free one. Tell em you just bought it and gripe a little. Now some dummy walk in there it cost about 30 bucks. I looked at them MES's and could tell it had too many bells and whistles for me.

    bigwheel
     
  4. ronp

    ronp Smoking Guru OTBS Member SMF Premier Member

    I doubt you need a new element, read the entire thread below.

    http://www.smokingmeatforums.com/for...lt+problem+fix

    If this happened before 1 year Masterbuilt would help you. You may contact them anyway and see what they say. They are pretty good at CS and may help you.

    1-706 256-3942 That is Amanda's direct #. Tell her Ron from smoking meat forums sent you.

    And good luck.
     
  5. wesb

    wesb Fire Starter

    thanks for the link ron, that's about what i've been finding when i do a google search, only better. i got the back taken off and a few screws out, then my little girls started getting sick, just never got back to it. hope it works, i'm sure that's the problem. folks at work are craven' some q [​IMG]
     
  6. fishawn

    fishawn Smoking Fanatic

    I just replaced the other heating element connector on mine today. Did the first one about a year ago. She's working like a champ now.
     

Share This Page