MES issues

Discussion in 'Electric Smokers' started by phil allen, Oct 25, 2015.

  1. Planned on doing two 6lb brisket flats today in my 1 year old MES 30 w/mailbox mod.

    Ended up being a brutal day with the MES.

    Got up and started the preheat at 3:30am, problems right away, couldn't get it up to temp at all. Cabinet temp wouldn't break 180, had it set for 230. It was like whatever relay that kicks the heating element on wasn't doing the kicking. Finally was able to get it to hold around 220ish, but had to set it to the max of 275 to get it there.

    Ran it last night for about an hour and a half at 230 drying pellets, worked fine then.

    Using an igrill with one probe high and one low, air vent open with a 4" stack.

    Any suggestions?

    My set up.

  2. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Might be low voltage due to the extension cord... or poor plug connection..

    Fixing a plug....

  3. Yep, I had a similar problem almost immediately after taking my MES out of the box. Employing the KISS method I decided to swap to a bigger gauge ext cord becore I messed with the unit at all. It worked like a champ after that.
  4. Thanks fellas. It's funny, I unplugged it and plugged it back in a couple times, and the last time it seemed like that's when I finally got it to break the 200 mark. Figured it had to do with resetting something inside the unit, but what you all are saying sounds like the ticket.

Share This Page