MES 40 Wiring Problem

Discussion in 'Masterbuilt Electric Smoker (MES) Owners' started by markk, Jan 28, 2012.

  1. markk

    markk Smoke Blower

    During a pastrami smoke this morning, went out and found the smoker temperature going down. Took the meat out and got into the oven, have to finish it like this I guess. Well since I have done a lot of reading on this site and there are many posts on this issue I knew where to start. Fortunately this is a newer MES and it has the access panel on the rear, removed and found the issue right away. Will have to pick up a stainless steel connector and a piece of wire as there is not enough extra wire to reconnect.

    [​IMG]
     
  2. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    Mark, morning... the connectors burn off due to a poor connection = high amp draw.... You could solder the wire to the element leg using silver solder and it might last forever.... Be sure to clean the leg really well with something  to get rid of the oxidation which ever way you fix it...

    Dave
     
  3. I bought high temp wire and high temp connectors at an appliance parts store. Bought a used older style MES 40 so I took whole back off and rewired the whole thing.

    Randy
     
  4. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    My ends burned up too, and I just crimped on cheapie terminal ends to get thru the smoke.  That was a year ago, and they're still working OK

    Todd
     
  5. markk

    markk Smoke Blower

    My brother in law had the same problem last summer, only his was an older model. We had to drill out all the rear panel rivets, but there was enough extra wire to just crimp on a new connector. I will have to locate some high temp wire when I get off of the night shift.

    Thanks for all the input everyone.
     

Share This Page