Maverick 732 problem

Discussion in 'Meat Thermometers' started by danbono, Sep 29, 2013.

  1. danbono

    danbono Master of the Pit OTBS Member

    HI All I just started having a problem with my 1 year old Maverick 732.The numbers on the remote seem to go out at times, the other numbers still show on unit by the pit. I changed the batteries in the remote and the same thing happens.When the problems comes all I get is beeps?

    Any one else  also came across this problem?

    Thanks Dan

    PS I love my Maverick 732 when it is working right.
     
  2. davidhef88

    davidhef88 Master of the Pit OTBS Member

    I haven't had that problem with mine.  Hopefully someone will be along with an answer for you.
     
  3. I seem to have a problem with my 732 with the box temps yet the meat temps seem to be right. It could be a wire issue. Had this from day one.
     
  4. garyinmd

    garyinmd Meat Mopper SMF Premier Member

    Are you pushing the limit on distance, the only time mine does that is if I am on the edge of the range.  Also might want to check batteries in the other half, not sure how they push the signal but worth a try.

    Gary
     
  5. pgsmoker64

    pgsmoker64 Master of the Pit Group Lead OTBS Member

    Sounds like you might have a connection issue.  Check the battery compartment and make sure your contacts are positioned well and not pushed in or corroded.  Also make sure your connections on the probes are good as well.

    If that doesn't work give the Mav customer service a call.

    Good luck,

    Bill
     
  6. danbono

    danbono Master of the Pit OTBS Member

    Hi All For some reason after I posted the Maverick started working the it was supposed too? Might have been the new batteries. Are there batteries in the other half? I don't see a battery compartment but do see 4 litte screws.

    Thanks Dan
     
  7. garyinmd

    garyinmd Meat Mopper SMF Premier Member

    There are batteries in the other unit. It has the screws to make water tight.
     
  8. mdboatbum

    mdboatbum Master of the Pit OTBS Member

    Yeah, change the batteries in both units at the same time. The transmitter batteries are likely as low or lower than the receiver batteries.
     
  9. deansomers

    deansomers Smoke Blower

    Is this the unit that most of you use that is sold by one of the members here?
     
  10. cmayna

    cmayna Master of the Pit OTBS Member SMF Premier Member

    Yup,

    Mine has worked like a champ.
     
  11. danbono

    danbono Master of the Pit OTBS Member

    Hi All couldn't think of cooking/smoking without the Maverick 732, best $ I've spent on cooking stuff.

    Dan
     
  12. I had serious problems with two units, one of which was one-year-old and the other was new. I called customer service and they told me to send them back for testing, which I did. A short time later, they sent me two new units.
     

Share This Page