HELP!!!! MES 30 won't stay running mid smoke...

Discussion in 'Electric Smokers' started by bj77, Jun 6, 2014.

  1. bj77

    bj77 Fire Starter

    My MES 30 is full of meat and it will NOT stay running. It's very random sometimes 15 min sometimes 35-40 sometimes just a few min. I has been working fine and hasn't moved.  the whole thing shuts off.   Some times when I restart it the screen fills with 8's and cycles down 7..6..5...etc.  has anyone experienced anything like this?? I really don't want to sit in the garage restarting the smoker all night. [​IMG]
     
  2. hillbillyrkstr

    hillbillyrkstr Master of the Pit Group Lead

    I'd call masterbuilt customer service ASAP. Your not gonna get any smoking done like that.

    I've never had that happen to me but it sounds like something electric has fried. The customer support is pretty good with masterbuilt.
     
  3. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    unplug it, to reset the electronics..... be sure to set the timer..... and temp.....
     
  4. geerock

    geerock Master of the Pit SMF Premier Member

    ........
    or you may have the famous bad controller / wiring issue.
    Yeah, masterbuilt has pretty good customer service. They have certainly had enough calls to practice on.
     
  5. Oh boy.......another Masterbuilt wiring issue!!!   Finish your meat in the oven so you don't waste it.  I won't even go into how I feel about Masterbuilt products (former and never again owner).

    Good luck my friend.
     
  6.  Hey Geerock......LOL @ enough calls to practice on [​IMG]
     
  7. daveomak

    daveomak Smoking Guru OTBS Member SMF Premier Member

    77, afternoon..... did you try resetting the electronics, by unplugging the smoker.......
     

Share This Page