Cold Start

Discussion in 'Pellet Smokers' started by smokin monkey, Nov 22, 2015.

  1. smokin monkey

    smokin monkey Master of the Pit Group Lead OTBS Member SMF Premier Member

    Over the last two days I have encounted this problem when I try and start my GMG DB.

    It is shut down in the correct way, drop temp to 65'C (149F). Fan on etc.

    When I have come to start it on Saturday and today Sunday both days with an outside temperature of 0'C (32F) it goes through the start up procedure but no smoke no heat? When I have inspected the fire pot it's empty of pellets, and auger is not running? But fan is running. Handful of pellets in fire pot lit with gas torch, re-assemble temperature starts to rise the auger kicks in and feeds fire pot. Never had this problem on warmer days. Anybody else have this problem or is it only my DB that's a Summer Only Smoker?
     
    Last edited: Nov 22, 2015
  2. westby

    westby Smoking Fanatic

    Is it possible that your heat rod is out?
     
  3. smokin monkey

    smokin monkey Master of the Pit Group Lead OTBS Member SMF Premier Member

    Hi Westby, not checked the heat rod, but why would this stop the Auger putting pellets into the Fire Pot?
     
  4. westby

    westby Smoking Fanatic

    Not sure - just spitballing.  I'm not too familiar with GMG, but thought maybe there was a sensor that wouldn't allow for the auger to turn if it wasn't heating or at temp.  I'm not sure why else the auger wouldn't turn - especially if it turned when you manually lit it.

    The GMG guys on pelletheads.com may be able to help you out.  Otherwise - call GMG for some tech support.  Let us know what you find out.
     
  5. smokin monkey

    smokin monkey Master of the Pit Group Lead OTBS Member SMF Premier Member

    Thanks Westby, will firstly check the rod then Give GMG a call 👍
     
  6. mowin

    mowin Master of the Pit

    Call GMG customer support. There CS is second to none. Don't hesitate. Call ASAP..
     
  7. smokin monkey

    smokin monkey Master of the Pit Group Lead OTBS Member SMF Premier Member

    Called GMG support, ask me to check if the heater rod got hot.

    Belive it or not, removed Ranks, Grease Tray and Baffles, started machine, instantly Auger started and put an handful of pellets into pot, but no heat from Heater Rod. GMG are sending replacement Heater Rod.

    So, I am just curious, the next cold period we have will the Auger run or not??? As I belive that starting without pellets in the Fire Pot caused the Heater Rod to fail.

    Will be intresting!
     

Share This Page