AMNPS not staying lit in MES2 30" electric smoker

Discussion in 'Electric Smokers' started by husker3in4, Feb 6, 2016.

  1. husker3in4

    husker3in4 Smoke Blower

    I know there have been threads about this, I searched google too. I havent been able to find the right answer so far.

    So anyway, I have the AMNPS, and an MES gen 2 30" smoker. I got the AMNPS last fall, and after a couple of tries, I got the AMNPS to light correctly and burn all the way thru. Fast forward to this weekend. I am smoking 6 butts for a friends event, and am smoking 3 at a time. The first 3 was thursday night, it was probably 20 degrees, little to no wind. I nuked the pellets in a glass bowl for 2 mins, put them in the AMNPS, got it lit, let it burn for 10 mins, blew it out and put it in the smoker. It was producing good smoke when it went into the smoker. I pulled the loader out 2" and left the chip pan in (as per instructions for MES2). When I pulled the butts off the 12 hours later, I discovered only the first half of the first row burned. The middle row was all black, and the 3rd row was light brown (as it was when it first went into the smoker.

    Now I have a 20 lb bag of apple pellets, I just roll the bag closed and seal with a clip. That is why I nuke them before I use them.

    So last night I tried the other 3 butts, followed the same steps, except this time I nuked for 2 mins, 1 min and 1 min, thinking they must have had too much moisture. But, same result (1st half of 1st row burned, then whole pellets that are blackened, then last row untouched.)

    I have one more smoke tonight, with just 1 butt, for my superbowl party tomorrow, and I need it to smoke! Do I need to nuke it longer?

    I am placing the AMNPS over the water pan hole as per the instructions, I just take the water pan out alltogether.

    Help please!
  2. Blow out aND blow in it till it flames up again, repeat till its glowing red. When you have achieved this put pellets on top of the lit end to make "full" again. This is the method I use, once I started putting pellets back on top of the lit area she burns the whole way. Before I had same issue as you.
  3. daricksta

    daricksta Master of the Pit OTBS Member

    Todd Johnson has said there are airflow problems with the Gen 2 smokers. This has been a constant complaint with guys using the AMNPS inside them. A number of them have reported that a mailbox mod solved the problem. You can search SMF for photos and posts on how to build one. I own a MES 30 Gen 1 which the AMNPS was designed for. Luckily, it works fine inside my smoker.

Share This Page