732 busted probe

Discussion in 'Meat Thermometers' started by rhode-rage, Apr 4, 2011.

  1. rhode-rage

    rhode-rage Newbie

    OK - so I got carried away and built myself a smoker. First ribs out were great. Still on a learning curve to keep fire in check. The other night's chickens were a near disaster when water tray dryed out and had nice fireball of grease go up. How are you supposed to cook chicken @ 300degrees?

    I bought a e-732 - worked great, once. I cleaned the probes, "do not emerse" i guess means "do not clean". So does anyone know if replacments for this model are avalible anywhere? I have found the earlier e-73 probes but not the new ones. If this had not happened the thing worked great,.. the first time.

    The chicken experience - the meat probe was way off and I did not catch on, but they were saved and turned out reasonable concidering.
     
    Last edited: Apr 4, 2011
  2. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    Welcome To SMF!

    I've got over (300) sold, and only (2) returned so far.

    Did you push the end in all the way?

    Call Maverick for warranty service

    (732) 417-9666

    Todd
     
  3. bmudd14474

    bmudd14474 Guest

    Call MAverick and they will most likely send you some. 
     
  4. rw willy

    rw willy Smoking Fanatic OTBS Member

    Immersed & clean are two different things.  i clean mine.  However I do not immerse them in liquid.  I wipe the probes off with a damp soapy wash cloth/sponge.  Then wipe with a clean towel to rinse.  Don't let liquid in the cable end.  Also its good to wipe them with an antseptic wipe prior to insertion.

    Now get over to Roll Call and introduce yourself and tell us about your smoker.
     
    Last edited: Apr 4, 2011
  5. smokinal

    smokinal Smoking Guru Staff Member Moderator OTBS Member SMF Premier Member

    I clean my probes with rubbing alcohol. The grease comes right off & they get sanitized at the same time.
     
  6. venture

    venture Smoking Guru OTBS Member

    I guess I have been lucky.  I have never had a probe go bad.  I carefully wrap the wires in aluminum foil and very carefully clean the probes so no moisture reaches the wire.

    Good luck and good smoking!
     
  7. fife

    fife Master of the Pit

    I have not had any problum with mine works very well.
     
  8. jp61

    jp61 Master of the Pit SMF Premier Member

    Not a good sign, IMO!!! I used my ET-732 two (2) times and was very careful when cleaning it. Put a chicken in the oven for dinner tonight using only the "Food" probe. Few minutes later I thought, what the heck, let me check the oven temp. Plug in the "Barbecue" probe and this is what it shows... LLL Nice!!! Just what I needed, another pain in the arse. Guess I'll be calling and/or e-mailing Maverick.
     
  9. tjohnson

    tjohnson Smoking Guru Staff Member Moderator Insider OTBS Member SMF Premier Member

    Don't panic yet.

    The plug end of the new ET-732 probes actually seats a little harder than the old ET-73.

    Pull out the plug end and reseat it in the hole.

    If LLL still happens, swap the probes and you can tell if it's one probe or both.

    Todd
     
  10. jp61

    jp61 Master of the Pit SMF Premier Member

    Thanks for trying to help Todd. I did all that plus CPR..... the barbecue probe is dead.
     

Share This Page